Get In Touch

Some systems are experiencing issues.

05.03.2026

Compute
1 month ago —
Fixed

Fixed

2 days ago —

Some compute nodes showed performance issues. These got drained sequentially to avoid impact on workloads. Full performance has been restored.

Investigating

2 days ago —

Currently investigating.

1 month ago —

We are currently investigating reported performance issues with compute in our Region HAM1.

Incident UUID cf6aab75-a5be-447e-8532-e1a58cdfa673