Get In Touch

Some systems are experiencing issues.

26.03.2026

Network
3 weeks ago —
Fixed

Fixed

2 days ago —

A change in configuration caused an unexpected network outage for the region for ~2 minutes. Full connectivity is restored.

Investigating

2 days ago —

Currently investigating.

3 weeks ago —

We are investigating connectivity issues regarding our network in Region FES.

Incident UUID 44ee2db9-82bb-44c4-8242-b63d4a777b99